import Foundation
let pattern = #"(?=\b.{48}\b)[A-Z0]*0[A-Z0]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
AUSGKAJDGAYGDKJAA0GDKJAGDJKASGDKJASGDKYQGWUDVASA
AUSGKAJDGAYGDKJAAAGDKJAGDJKASGDKJASGDKYQGWUDVASA
AUSGKAJDGAYGDKJAA0GDKJAGDJKASGDKJASGDKYQGWUDVASAB
AUSGKAJDGAYGDKJAA0KJAGDJKASGDKJASGDKYQGWUDVASA
quick brown fox AUSGKAJDGAYGDKJAS0GDKJAGDJKASGDKJASGDKYQGWUDVAS0 jumped over the fence
quick brown fox AUSGKAJDGAYGDKJAS0GDKJAGDJKASGDKJASGAAAAAAADKYQGWUDVAS0 jumped over the fence
quick brown fox AUSGKAJDGAYGDKJASBGDKJAGDJKASGDKJASGDKYQGWUDVASA jumped over the fence
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)