$re = '/(?=\b.{48}\b)[A-Z0]*0[A-Z0]*/m';
$str = 'AUSGKAJDGAYGDKJAA0GDKJAGDJKASGDKJASGDKYQGWUDVASA
AUSGKAJDGAYGDKJAAAGDKJAGDJKASGDKJASGDKYQGWUDVASA
AUSGKAJDGAYGDKJAA0GDKJAGDJKASGDKJASGDKYQGWUDVASAB
AUSGKAJDGAYGDKJAA0KJAGDJKASGDKJASGDKYQGWUDVASA
quick brown fox AUSGKAJDGAYGDKJAS0GDKJAGDJKASGDKJASGDKYQGWUDVAS0 jumped over the fence
quick brown fox AUSGKAJDGAYGDKJAS0GDKJAGDJKASGDKJASGAAAAAAADKYQGWUDVAS0 jumped over the fence
quick brown fox AUSGKAJDGAYGDKJASBGDKJAGDJKASGDKJASGDKYQGWUDVASA jumped over the fence';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);