#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "{nbr}[\r\n]+"
Local $sString = "This is a single long line, and it has to be" & @CRLF & _
"in one line, though the SideCI thing (as a " & @CRLF & _
"coding regulation) I have to line break." & @CRLF & _
"But this line stays short." & @CRLF & _
"And this line too." & @CRLF & _
"And the backslash such as \" & @CRLF & _
"won't work. Nor /" & @CRLF & _
"won't work." & @CRLF & _
"My alternative way is to use {nbr}" & @CRLF & _
"strings and replace them later." & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)