re = /{nbr}[\r\n]+/
str = 'This is a single long line, and it has to be
in one line, though the SideCI thing (as a
coding regulation) I have to line break.
But this line stays short.
And this line too.
And the backslash such as \\
won\'t work. Nor /
won\'t work.
My alternative way is to use {nbr}
strings and replace them later.
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result