use strict;
my $str = 'This is a single long line, and it has to be
in one line, though the SideCI thing (as a
coding regulation) I have to line break.
But this line stays short.
And this line too.
And the backslash such as \\
won\'t work. Nor /
won\'t work.
My alternative way is to use {nbr}
strings and replace them later.
';
my $regex = qr/{nbr}[\r\n]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";