package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{nbr}[\r\n]+`)
var str = `This is a single long line, and it has to be
in one line, though the SideCI thing (as a
coding regulation) I have to line break.
But this line stays short.
And this line too.
And the backslash such as \
won't work. Nor /
won't work.
My alternative way is to use {nbr}
strings and replace them later.
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}