const regex = /{nbr}[\r\n]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{nbr}[\\r\\n]+', 'g')
const str = `This is a single long line, and it has to be
in one line, though the SideCI thing (as a
coding regulation) I have to line break.
But this line stays short.
And this line too.
And the backslash such as \\
won't work. Nor /
won't work.
My alternative way is to use {nbr}
strings and replace them later.
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);