using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1]{1}[7-9]{1}\d{6}$|^[2]{1}[0-2]{1}\d{6}$";
string input = @"17254354
23464515
16434553
13462164
12564562
22346612
18613232
19561322
20351615
21561321
11326562
10320132";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}