import re
regex = re.compile(r"^[1]{1}[7-9]{1}\d{6}$|^[2]{1}[0-2]{1}\d{6}$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("17254354\n"
"23464515\n"
"16434553\n"
"13462164\n"
"12564562\n"
"22346612\n"
"18613232\n"
"19561322\n"
"20351615\n"
"21561321\n"
"11326562\n"
"10320132")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")