import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1]{1}[7-9]{1}\\d{6}$|^[2]{1}[0-2]{1}\\d{6}$";
final String string = "17254354\n"
+ "23464515\n"
+ "16434553\n"
+ "13462164\n"
+ "12564562\n"
+ "22346612\n"
+ "18613232\n"
+ "19561322\n"
+ "20351615\n"
+ "21561321\n"
+ "11326562\n"
+ "10320132";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}