# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/:(.+)@//gm;t' <<< "information:TH@THinformation@information
information:information:UD@UDinformation@information"