use strict;
my $str = 'information:TH@THinformation@information
information:information:UD@UDinformation@information';
my $regex = qr/:(.+)@/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";