const regex = /:(.+)@/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':(.+)@', 'gm')
const str = `information:TH@THinformation@information
information:information:UD@UDinformation@information`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);