# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\s|^)([^\\]+)(?=\\u|\\\\u)/\1 /gm;t' <<< "blabla whoaaa\\ud83d\\udc4f blabla blabla whoaaa\\ud83d\\udc4f\\ud83d\\udc4f blabla\\ud83d blabla\\ud83d blabla\\ud83d"