const regex = /(?:\s|^)([^\\]+)(?=\\u|\\\\u)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s|^)([^\\\\]+)(?=\\\\u|\\\\\\\\u)', 'gm')
const str = `blabla whoaaa\\\\ud83d\\\\udc4f blabla blabla whoaaa\\\\ud83d\\\\udc4f\\\\ud83d\\\\udc4f blabla\\\\ud83d blabla\\\\ud83d blabla\\\\ud83d`;
const subst = `\1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);