re = /(?:\s|^)([^\\]+)(?=\\u|\\\\u)/m
str = 'blabla whoaaa\\\\ud83d\\\\udc4f blabla blabla whoaaa\\\\ud83d\\\\udc4f\\\\ud83d\\\\udc4f blabla\\\\ud83d blabla\\\\ud83d blabla\\\\ud83d'
subst = '\\1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result