using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s|^)([^\\]+)(?=\\u|\\\\u)";
string substitution = @"\1 ";
string input = @"blabla whoaaa\\ud83d\\udc4f blabla blabla whoaaa\\ud83d\\udc4f\\ud83d\\udc4f blabla\\ud83d blabla\\ud83d blabla\\ud83d";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}