#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?mi)^((?![0-9]+-[0-9]+).*?)(\bingenieur\b.*)"
Local $sString = "etudiant -: ingenieur etudes et developpement" & @CRLF & _
"http://www.doyoubuzz.com/profilen" & @CRLF & _
"experiences " & @CRLF & _
"ingenieur" & @CRLF & _
"2018-2014 ingenieur " & @CRLF & _
"331 ingenieur" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"29 rue de la terrasse Ingenieur Centrale Lyon / Supélec " & @CRLF & _
"93160 NOISY LE GRAND ingenieur " & @CRLF & _
"09 66 11 10 93 Expertise en instrumentation industrielle, " & @CRLF & _
"06 44 25 90 09 automatisation ingenieur & marketing opérationnel " & @CRLF & _
"email.email@wanadoo.fr Bilingue anglais ingenieur"
Local $sSubst = "$1<i>$2</i>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)