import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?mi)^((?![0-9]+-[0-9]+).*?)(\\bingenieur\\b.*)";
final String string = "etudiant -: ingenieur etudes et developpement\n"
+ "http://www.doyoubuzz.com/profilen\n"
+ "experiences \n"
+ "ingenieur\n"
+ "2018-2014 ingenieur \n"
+ "331 ingenieur\n\n\n"
+ "29 rue de la terrasse Ingenieur Centrale Lyon / Supélec \n"
+ "93160 NOISY LE GRAND ingenieur \n"
+ "09 66 11 10 93 Expertise en instrumentation industrielle, \n"
+ "06 44 25 90 09 automatisation ingenieur & marketing opérationnel \n"
+ "email.email@wanadoo.fr Bilingue anglais ingenieur";
final String subst = "$1<i>$2</i>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}