re = /(?mi)^((?![0-9]+-[0-9]+).*?)(\bingenieur\b.*)/m
str = 'etudiant -: ingenieur etudes et developpement
http://www.doyoubuzz.com/profilen
experiences
ingenieur
2018-2014 ingenieur
331 ingenieur
29 rue de la terrasse Ingenieur Centrale Lyon / Supélec
93160 NOISY LE GRAND ingenieur
09 66 11 10 93 Expertise en instrumentation industrielle,
06 44 25 90 09 automatisation ingenieur & marketing opérationnel
email.email@wanadoo.fr Bilingue anglais ingenieur'
subst = '$1<i>$2</i>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result