# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?mi)^((?![0-9]+-[0-9]+).*?)(\bingenieur\b.*)"
test_str = ("etudiant -: ingenieur etudes et developpement\n"
"http://www.doyoubuzz.com/profilen\n"
"experiences \n"
"ingenieur\n"
"2018-2014 ingenieur \n"
"331 ingenieur\n\n\n"
"29 rue de la terrasse Ingenieur Centrale Lyon / Supélec \n"
"93160 NOISY LE GRAND ingenieur \n"
"09 66 11 10 93 Expertise en instrumentation industrielle, \n"
"06 44 25 90 09 automatisation ingenieur & marketing opérationnel \n"
"email.email@wanadoo.fr Bilingue anglais ingenieur")
subst = "$1<i>$2</i>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.