#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\B-)?+\d++(?:[.,]\d++)?+"
Local $sString = "1" & @CRLF & _
"2+-1" & @CRLF & _
"2+(-1)" & @CRLF & _
"-2+-2" & @CRLF & _
"-2-2.1" & @CRLF & _
"" & @CRLF & _
"x-12--13,2=0.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")