re = /(?:\B-)?+\d++(?:[.,]\d++)?+/m
str = '1
2+-1
2+(-1)
-2+-2
-2-2.1
x-12--13,2=0.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end