package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\B-)?+\d++(?:[.,]\d++)?+`)
var str = `1
2+-1
2+(-1)
-2+-2
-2-2.1
x-12--13,2=0.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}