using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\B-)?+\d++(?:[.,]\d++)?+";
string input = @"1
2+-1
2+(-1)
-2+-2
-2-2.1
x-12--13,2=0.1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}