$re = '/(?:\B-)?+\d++(?:[.,]\d++)?+/m';
$str = '1
2+-1
2+(-1)
-2+-2
-2-2.1
x-12--13,2=0.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);