import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(?=\\w{5})\\w*\\d\\w*(?!\\S)";
final String string = "There is some random information here\n"
+ "This includes item p23344dd5 as well as other info\n"
+ "K3455 $100.00\n"
+ "Last part number here 5551234\n"
+ "a1aa\n"
+ "1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}