const regex = new RegExp('(?<!\\S)(?=\\w{5})\\w*\\d\\w*(?!\\S)', 'g')
const str = `There is some random information here
This includes item p23344dd5 as well as other info
K3455 \$100.00
Last part number here 5551234
a1aa
1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}