import re
regex = re.compile(r"(?<!\S)(?=\w{5})\w*\d\w*(?!\S)")
test_str = ("There is some random information here\n"
"This includes item p23344dd5 as well as other info\n"
"K3455 $100.00\n"
"Last part number here 5551234\n"
"a1aa\n"
"1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")