use strict;
my $str = 'There is some random information here
This includes item p23344dd5 as well as other info
K3455 $100.00
Last part number here 5551234
a1aa
1';
my $regex = qr/(?<!\S)(?=\w{5})\w*\d\w*(?!\S)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}