import Foundation
let pattern = #"(?<!\S)(?=\w{5})\w*\d\w*(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
There is some random information here
This includes item p23344dd5 as well as other info
K3455 $100.00
Last part number here 5551234
a1aa
1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)