#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:(?<environment>qa|stage|dev|preprod)\S*?\.)?(?<hostname>\w+)\.(?<domain>\w+)$"
Local $sString = "https://example.test.qa.sub.hostname.com" & @CRLF & _
"https://example.test.stage.coonect.hostname.com" & @CRLF & _
"https://example.qa.hostname.com" & @CRLF & _
"https://example.stage.hostname.com" & @CRLF & _
"https://example.hostname.com" & @CRLF & _
"https://ops-cert-stage-beta.apps.sub-test.minor.qa.test.sub.hostname.com" & @CRLF & _
"https://ops-cert-qa-beta.apps.sub-test.minor.qa.test.sub.hostname.com" & @CRLF & _
"https://ops-cert-qa.apps.sub-test.minor.qa.test.sub.hostname.com" & @CRLF & _
"https://ops-cert-stage.apps.sub-test.minor.qa.test.sub.hostname.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")