using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(?<environment>qa|stage|dev|preprod)\S*?\.)?(?<hostname>\w+)\.(?<domain>\w+)$";
string input = @"https://example.test.qa.sub.hostname.com
https://example.test.stage.coonect.hostname.com
https://example.qa.hostname.com
https://example.stage.hostname.com
https://example.hostname.com
https://ops-cert-stage-beta.apps.sub-test.minor.qa.test.sub.hostname.com
https://ops-cert-qa-beta.apps.sub-test.minor.qa.test.sub.hostname.com
https://ops-cert-qa.apps.sub-test.minor.qa.test.sub.hostname.com
https://ops-cert-stage.apps.sub-test.minor.qa.test.sub.hostname.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}