re = /\b(?:(?<environment>qa|stage|dev|preprod)\S*?\.)?(?<hostname>\w+)\.(?<domain>\w+)$/m
str = 'https://example.test.qa.sub.hostname.com
https://example.test.stage.coonect.hostname.com
https://example.qa.hostname.com
https://example.stage.hostname.com
https://example.hostname.com
https://ops-cert-stage-beta.apps.sub-test.minor.qa.test.sub.hostname.com
https://ops-cert-qa-beta.apps.sub-test.minor.qa.test.sub.hostname.com
https://ops-cert-qa.apps.sub-test.minor.qa.test.sub.hostname.com
https://ops-cert-stage.apps.sub-test.minor.qa.test.sub.hostname.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end