using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\r\n]*[^\r\n]+(?:[\r\n]+[^\r\n]+)*)[\r\n]+$";
string substitution = @"$1";
string input = @"aaaaaaaaaa
11111111111111111111111
2222222222222222222222222222222222222
333333333333333333333333333333333333333
44
55
67
8
9
90
0
-
=-
=
l
j
g
f
d
s
x
cv
b
n
m
j
h
d
d
g
uj
j
j
h
g
f
gt
t
t
t
tt
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}