const regex = /^([\r\n]*[^\r\n]+(?:[\r\n]+[^\r\n]+)*)[\r\n]+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\r\\n]*[^\\r\\n]+(?:[\\r\\n]+[^\\r\\n]+)*)[\\r\\n]+$', '')
const str = `aaaaaaaaaa
11111111111111111111111
2222222222222222222222222222222222222
333333333333333333333333333333333333333
44
55
67
8
9
90
0
-
=-
=
l
j
g
f
d
s
x
cv
b
n
m
j
h
d
d
g
uj
j
j
h
g
f
gt
t
t
t
tt
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);