import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\r\\n]*[^\\r\\n]+(?:[\\r\\n]+[^\\r\\n]+)*)[\\r\\n]+$";
final String string = "aaaaaaaaaa\n"
+ "11111111111111111111111\n"
+ "2222222222222222222222222222222222222\n"
+ "333333333333333333333333333333333333333\n"
+ "44\n"
+ "55\n"
+ "67\n"
+ "8\n"
+ "9\n"
+ "90\n"
+ "0\n"
+ "-\n"
+ "=-\n"
+ "=\n"
+ "l\n"
+ "j\n"
+ "g\n"
+ "f\n"
+ "d\n"
+ "s\n\n"
+ "x\n"
+ "cv\n"
+ "b\n"
+ "n\n"
+ "m\n"
+ "j\n"
+ "h\n"
+ "d\n"
+ "d\n\n"
+ "g\n"
+ "uj\n"
+ "j\n"
+ "j\n"
+ "h\n"
+ "g\n"
+ "f\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n"
+ "gt\n"
+ "t\n"
+ "t\n\n"
+ "t\n\n\n\n\n\n\n\n\n\n\n"
+ "tt\n\n\n\n\n\n\n\n\n\n\n\n\n\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}