import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)rel\\s*=\\s*['\"]?amphtml[^>]+href\\s*=\\s*['\"]?([^'\"]*)['\"]?|href\\s*=\\s*['\"]?([^\"']*)['\"]?[^>]+rel\\s*=\\s*['\"]?amphtml['\"]?";
final String string = "<link rel=\"amphtml\" href=\"https://amp.blick.ch/news/schweiz/mittelland/billett-entzug-weil-er-red-bull-getrunken-hat-jetzt-fordert-opfer-adnan-mursula-ich-will-eine-entschaedigung-id7543563.html\">\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}