// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)rel\s*=\s*['"]?amphtml[^>]+href\s*=\s*['"]?([^'"]*)['"]?|href\s*=\s*['"]?([^"']*)['"]?[^>]+rel\s*=\s*['"]?amphtml['"]?"#).unwrap();
let string = "<link rel=\"amphtml\" href=\"https://amp.blick.ch/news/schweiz/mittelland/billett-entzug-weil-er-red-bull-getrunken-hat-jetzt-fordert-opfer-adnan-mursula-ich-will-eine-entschaedigung-id7543563.html\">
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}