const regex = /(?i)rel\s*=\s*['"]?amphtml[^>]+href\s*=\s*['"]?([^'"]*)['"]?|href\s*=\s*['"]?([^"']*)['"]?[^>]+rel\s*=\s*['"]?amphtml['"]?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)rel\\s*=\\s*[\'"]?amphtml[^>]+href\\s*=\\s*[\'"]?([^\'"]*)[\'"]?|href\\s*=\\s*[\'"]?([^"\']*)[\'"]?[^>]+rel\\s*=\\s*[\'"]?amphtml[\'"]?', 'g')
const str = `<link rel="amphtml" href="https://amp.blick.ch/news/schweiz/mittelland/billett-entzug-weil-er-red-bull-getrunken-hat-jetzt-fordert-opfer-adnan-mursula-ich-will-eine-entschaedigung-id7543563.html">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}