import re
regex = re.compile(r"(?i)rel\s*=\s*['\"]?amphtml[^>]+href\s*=\s*['\"]?([^'\"]*)['\"]?|href\s*=\s*['\"]?([^\"']*)['\"]?[^>]+rel\s*=\s*['\"]?amphtml['\"]?")
test_str = ("<link rel=\"amphtml\" href=\"https://amp.blick.ch/news/schweiz/mittelland/billett-entzug-weil-er-red-bull-getrunken-hat-jetzt-fordert-opfer-adnan-mursula-ich-will-eine-entschaedigung-id7543563.html\">\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")