$re = '/(?i)rel\s*=\s*[\'"]?amphtml[^>]+href\s*=\s*[\'"]?([^\'"]*)[\'"]?|href\s*=\s*[\'"]?([^"\']*)[\'"]?[^>]+rel\s*=\s*[\'"]?amphtml[\'"]?/';
$str = '<link rel="amphtml" href="https://amp.blick.ch/news/schweiz/mittelland/billett-entzug-weil-er-red-bull-getrunken-hat-jetzt-fordert-opfer-adnan-mursula-ich-will-eine-entschaedigung-id7543563.html">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);