use strict;
my $str = 'Valor del Fondo (Mill COP)
1,308,906.95
Valor fondo de
inversión (Mill COP)
230,942.51 Inversión inicial mínima (COP)\\';
my $regex = qr/valor(?:\s+del)?\s+fondo(?:\s+de\s+inversi[óo]n)?\D*(\d(?:[.,\d]*\d)?)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}