// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)valor(?:\s+del)?\s+fondo(?:\s+de\s+inversi[óo]n)?\D*(\d(?:[.,\d]*\d)?)").unwrap();
let string = "Valor del Fondo (Mill COP)
1,308,906.95
Valor fondo de
inversión (Mill COP)
230,942.51 Inversión inicial mínima (COP)\\";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}