$re = '/valor(?:\s+del)?\s+fondo(?:\s+de\s+inversi[óo]n)?\D*(\d(?:[.,\d]*\d)?)/mi';
$str = 'Valor del Fondo (Mill COP)
1,308,906.95
Valor fondo de
inversión (Mill COP)
230,942.51 Inversión inicial mínima (COP)\\';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);