import re
regex = re.compile(r"valor(?:\s+del)?\s+fondo(?:\s+de\s+inversi[óo]n)?\D*(\d(?:[.,\d]*\d)?)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Valor del Fondo (Mill COP)\n"
"1,308,906.95\n"
"Valor fondo de\n"
"inversión (Mill COP)\n"
" 230,942.51 Inversión inicial mínima (COP)\\")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")