#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\([/a-zA-Z0-9_\\-]+\))+$"
Local $sString = "(AAA/)(BBB/)(cc)(\)" & @CRLF & _
"(AAA/)xxxx(BBB/)(cc)" & @CRLF & _
"(mystring123/)" & @CRLF & _
"(\mystring123\)" & @CRLF & _
"(g)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")