using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\([/a-zA-Z0-9_\\-]+\))+$";
string input = @"(AAA/)(BBB/)(cc)(\)
(AAA/)xxxx(BBB/)(cc)
(mystring123/)
(\mystring123\)
(g)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}