$re = '~^(?:\([/a-zA-Z0-9_\\\\-]+\))+$~m';
$str = '(AAA/)(BBB/)(cc)(\\)
(AAA/)xxxx(BBB/)(cc)
(mystring123/)
(\\mystring123\\)
(g)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);