package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\([/a-zA-Z0-9_\\-]+\))+$`)
var str = `(AAA/)(BBB/)(cc)(\)
(AAA/)xxxx(BBB/)(cc)
(mystring123/)
(\mystring123\)
(g)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}